summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu.herrb@laas.fr>2006-05-14 16:22:24 +0000
committerMatthieu Herrb <matthieu.herrb@laas.fr>2006-05-14 16:22:24 +0000
commitdd38d3bd673cf830c2cd591fe1245909aa729892 (patch)
tree3c411c83fcf6ad1e17fa22a7844da202ff2d420a /configure.ac
parent6558ba4e62dba99f2a4d830f1c16f8d1c255b316 (diff)
Don't use AM_CONDITIONAL inside shell conditionals. Bugzilla #6916.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 542d8199a..306b41f20 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1053,11 +1053,11 @@ if test "x$XORG" = xyes -o "x$XGL" = xyes; then
XORG_OS_SUBDIR="linux"
XORG_OS_KBD="Lnx"
xorg_bus_linuxpci="yes"
- AM_CONDITIONAL(LNXACPI,false)
+ linux_acpi="no"
case $host_cpu in
ia64*)
linux_ia64=yes
- AM_CONDITIONAL(LNXACPI,true)
+ linux_acpi="yes"
;;
alpha*)
linux_alpha=yes
@@ -1065,7 +1065,7 @@ if test "x$XORG" = xyes -o "x$XGL" = xyes; then
xorg_bus_linuxpci="no"
;;
x86*)
- AM_CONDITIONAL(LNXACPI,true)
+ linux_acpi="yes"
;;
*)
;;
@@ -1282,6 +1282,7 @@ AM_CONDITIONAL([XORG_BUS_SPARC], [test "x$xorg_bus_sparc" = xyes])
AM_CONDITIONAL([XORG_LOADER_SPARC], [test "x$xorg_loader_sparcmuldiv" = xyes])
AM_CONDITIONAL([LINUX_IA64], [test "x$linux_ia64" = xyes])
AM_CONDITIONAL([LINUX_ALPHA], [test "x$linux_alpha" = xyes])
+AM_CONDITIONAL([LNXACPI], [test "x$linux_acpi" = xyes])
AM_CONDITIONAL([SOLARIS_USL_CONSOLE], [test "x$solaris_usl_console" = xyes])
AM_CONDITIONAL([SOLARIS_ASM_INLINE], [test "x$solaris_asm_inline" = xyes])
AM_CONDITIONAL(MFB, [test "x$XORG" = xyes])