summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDrew Parsons <Drew.Parsons@anu.edu.au>2009-10-29 20:04:49 +1100
committerDrew Parsons <dparsons@debian.org>2009-10-29 20:04:49 +1100
commit48dcb52fb56999b59d8b8ff037a127cbd4fddca1 (patch)
tree5421e4692b2c9f71dd25149098686792df1ee9cd /configure.ac
parent2686a3828720ee65a67896b74a9d02ca7f00e479 (diff)
Revert "By default, enable built-in fonts in configure script."
This reverts commit f7b940677eae414ab08ce41fe6bdb7253b7a7864. The built-in fonts (--enable-builtin-fonts) trigger a segfault with clients. That is, Xprt will build and run successfully with them, but when a client such as xpsimplehelloworld tries to print via Xprt, it segfaults. Since Xprint is deprecated, motivation is not high for fully debugging this problem. The workaround around will be to not use built-in fonts (i.e. reverting the previous commit to use --disable-builtin-fonts by default again), and build against libXfont 1.3 (rather than the latest libXfont 1.4, which has Xprint support removed).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a58c30340..48ca285d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -504,9 +504,9 @@ AC_ARG_ENABLE(install-libxf86config,
[Install libxf86config (default: disabled)]),
[INSTALL_LIBXF86CONFIG=$enableval],
[INSTALL_LIBXF86CONFIG=no])
-AC_ARG_ENABLE(builtin-fonts, AS_HELP_STRING([--enable-builtin-fonts], [Use only built-in fonts (default: use built-in fonts)]),
+AC_ARG_ENABLE(builtin-fonts, AS_HELP_STRING([--enable-builtin-fonts], [Use only built-in fonts (default: use external)]),
[BUILTIN_FONTS=$enableval],
- [BUILTIN_FONTS=yes])
+ [BUILTIN_FONTS=no])
AC_ARG_ENABLE(null-root-cursor, AS_HELP_STRING([--enable-null-root-cursor], [Use an empty root cursor (default: use core cursor)]),
[NULL_ROOT_CURSOR=$enableval],
[NULL_ROOT_CURSOR=no])