summaryrefslogtreecommitdiff
path: root/src/bitmap/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2014-05-15 22:44:38 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2014-05-23 17:21:00 -0700
commitc2b7758d268fd98e09c3e66a0e7717b47ff12a47 (patch)
treefe221051127d32bc2832638143121d3629317b0e /src/bitmap/Makefile.am
parenta81f1a9bd3cd0a9d45d93d5b9e392b4e08ac60f7 (diff)
Don't compile bitmap source files for disabled formats
pcfread.c is a special case - it's needed for either reading pcf files from disk (--enable-pcfformat) or from the builtin fonts in memory (--enable-builtins), so needed a new AM_CONDITIONAL case. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: RĂ©mi Cardona <remi@gentoo.org>
Diffstat (limited to 'src/bitmap/Makefile.am')
-rw-r--r--src/bitmap/Makefile.am24
1 files changed, 17 insertions, 7 deletions
diff --git a/src/bitmap/Makefile.am b/src/bitmap/Makefile.am
index 99682d9..0f2d10a 100644
--- a/src/bitmap/Makefile.am
+++ b/src/bitmap/Makefile.am
@@ -6,14 +6,24 @@ AM_CFLAGS = $(XFONT_CFLAGS) $(OS_CFLAGS) $(CWARNFLAGS)
noinst_LTLIBRARIES = libbitmap.la
libbitmap_la_SOURCES = \
- bdfread.c \
- bdfutils.c \
bitmap.c \
bitmapfunc.c \
bitmaputil.c \
bitscale.c \
- fontink.c \
- pcfread.c \
- pcfwrite.c \
- snfread.c \
- snfstr.h
+ fontink.c
+
+if XFONT_BDFFORMAT
+libbitmap_la_SOURCES += bdfread.c bdfutils.c
+endif
+
+if XFONT_PCF_OR_BUILTIN
+libbitmap_la_SOURCES += pcfread.c
+endif
+
+if XFONT_PCFFORMAT
+libbitmap_la_SOURCES += pcfwrite.c
+endif
+
+if XFONT_SNFFORMAT
+libbitmap_la_SOURCES += snfread.c snfstr.h
+endif