summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-12-27 11:01:35 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-12-30 08:48:04 -0800
commitfdcf9a9be6a5d453659beadec5d1a1fdbab9afaf (patch)
tree5f1d3bc12cf2e17e1d10c52988f4a9f1586bd262 /configure.ac
parent0d24378a6f08f5ab594ff552d60cf5f8f74bcb33 (diff)
Add AC_USE_SYSTEM_EXTENSIONS to expose non-standard extensions
Required on Solaris to expose definitions in system headers that are not defined in the XPG standards now that xtrans 1.3 defines _XOPEN_SOURCE to 600 on Solaris. Fixes build failures: fserve.c: In function 'fs_block_handler': fserve.c:1210:5: error: 'fd_mask' undeclared (first use in this function) fserve.c:1210:5: note: each undeclared identifier is reported only once for each function it appears in In file included from transport.c:67:0, from fstrans.c:28: Xtranssock.c: In function '_FontTransSocketINETConnect': Xtranssock.c:1421:19: error: 'INET6_ADDRSTRLEN' undeclared (first use in this function) Xtranssock.c:1421:19: note: each undeclared identifier is reported only once for each function it appears in Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Daniel Stone <daniel@fooishbar.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e0e81bb..3591a1a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,11 @@ AC_CONFIG_HEADERS([config.h include/X11/fonts/fontconf.h])
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
+# Set common system defines for POSIX extensions, such as _GNU_SOURCE
+# Must be called before any macros that run the compiler (like
+# AC_PROG_LIBTOOL) to avoid autoconf errors.
+AC_USE_SYSTEM_EXTENSIONS
+
# Initialize libtool
AC_PROG_LIBTOOL