summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2015-12-12 14:54:26 -0800
committerKeith Packard <keithp@keithp.com>2015-12-12 14:56:03 -0800
commiteefc0b0b908eb8533e704d7156ce983ad7891cc5 (patch)
treee3e2d999b36db9cf9b1fd4124d87e8f74be5497b /configure.ac
parent14488af0338191356c0177e3d0b5fa473ffbd59c (diff)
Revert "Add compiler warning flags". Leave warning fixes.
This reverts commit eb67d10ae82b364a4324e96ce53baaa4e5e75f97, but leaves the warning fixes in place; it looks like either I was confused, or something has changed so that XORG_DEFAULT_OPTIONS now pulls in the appropriate compiler warnings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index a555151..13c8c97 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,7 +25,6 @@ AC_INIT([libXfont2], [2.0.1],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXfont2])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
-AC_CONFIG_MACRO_DIR([m4])
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2 subdir-objects])
@@ -58,27 +57,6 @@ AC_CHECK_FUNCS([poll readlink])
# must first be located explicitly.
PKG_PROG_PKG_CONFIG
-with_cflags=""
-if test "x$GCC" = "xyes"; then
- CC_CHECK_FLAGS_APPEND([with_cflags], [CFLAGS], [\
- -Wall \
- -Wextra \
- -Wno-sign-compare \
- -Wno-missing-field-initializers \
- -Wno-unused-parameter \
- -Wstrict-prototypes \
- -Wmissing-prototypes \
- -fvisibility=hidden \
- -pipe \
- -fno-strict-aliasing \
- -ffunction-sections \
- -fdata-sections \
- -fno-strict-aliasing \
- -fdiagnostics-show-option \
- -fno-common])
-fi
-AC_SUBST([GCC_CFLAGS], $with_cflags)
-
#
# select libraries to include
#
@@ -239,8 +217,6 @@ case $host_os in
OS_CFLAGS=
;;
esac
-OS_CFLAGS="$OS_CFLAGS $GCC_CFLAGS"
-
AC_SUBST([OS_CFLAGS])
AC_CONFIG_FILES([Makefile