summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2023-06-20 15:46:23 -0700
committerDylan Baker <dylan@pnwbakers.com>2023-07-13 15:26:17 -0700
commit68e74d37b99f56bbd1a5f2fb8cb4ad6116f27bd3 (patch)
treeaab43287eff02394981c905bfef7b30f7d8fdb60 /man/Makefile.am
parentdf1bf4fe528a5a9eef420f78efb225e4696ac467 (diff)
add Meson build system
This is, I think, equal to the autotools build-system in every practical way. The man pages have hardcoded numbers. I think this is okay, as all modern operating systems seem to use the same man page numbering now. I've also chosen to not generate a config.h file with Meson. This makes using libXau as a subproject safer, since we don't have to worry about conflicting config.h files, plus there are only a couple of declarations that are actually used. This also saves some configure time in writing out an additional file.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 24c7aa3..0938fd2 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -36,7 +36,7 @@ libman_PRE = \
libman_DATA = $(libman_PRE:man=$(LIB_MAN_SUFFIX))
-EXTRA_DIST = $(libman_PRE)
+EXTRA_DIST = $(libman_PRE) meson.build
CLEANFILES = $(libman_DATA)