summaryrefslogtreecommitdiff
path: root/nls/zh_CN/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-13 22:53:36 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-13 22:53:36 +0000
commit7eee605e3aeed549d1053325a03027c5e8cbf71b (patch)
tree3cea3cc392af388deb1b7ded8b50889008ca2a6f /nls/zh_CN/Makefile.am
parent6769ccda88caf27d1441d335ef2b318a047a612b (diff)
- For now put xtrans in X11/Xtrans/X11, since libX11 is looking for it in <X11/...>XORG-6_8_99_7
- For Xcomposite and Xdamage, don't link the build system out of the xc tree - Link the public X11 headers into their own directory - Add links to XKeysymDB and XErrorDB - Add links to all the Xlib man pages - Add links to the lcUniConv subdirectory - Conditionally include config.h in Xlib source
Diffstat (limited to 'nls/zh_CN/Makefile.am')
-rw-r--r--nls/zh_CN/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/nls/zh_CN/Makefile.am b/nls/zh_CN/Makefile.am
new file mode 100644
index 00000000..b2b1c8a8
--- /dev/null
+++ b/nls/zh_CN/Makefile.am
@@ -0,0 +1,18 @@
+x11thislocaledir = @X11_LOCALEDIR@/$(shell basename `pwd`)
+
+EXTRA_DIST = XLC_LOCALE.pre Compose.pre
+
+dist_x11thislocale_DATA = XI18N_OBJS
+x11thislocale_DATA = XLC_LOCALE Compose
+
+# XXX: WCHAR32 definition <<-- WTF does this mean?
+XLC_LOCALE: XLC_LOCALE.pre
+ $(CPP) -traditional -DWCHAR32=1 -DXCOMM='#' - < $< > $@
+
+Compose: Compose.pre
+ $(CPP) -traditional -DXCOMM='#' - < $< > $@
+
+Compose.pre:
+ touch Compose.pre
+
+DISTCLEANFILES=XLC_LOCALE Compose