summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@apple.com>2010-07-12 16:52:12 -0700
committerJeremy Huddleston <jeremyhu@apple.com>2010-07-12 16:52:12 -0700
commita151346a2b7810e988f1de4b1e00b37672dc587a (patch)
tree32d91ffc361e6a87710caf7931dbb5dc425b1176 /configure.ac
parent89cc2e02e7c29ef9a02f0cfdf2090a2934f539e4 (diff)
launchd: Explicitly search /sbin
Previously, launchd wasn't found if /sbin wasn't in the user's PATH. https://bugs.freedesktop.org/show_bug.cgi?id=29028 Signed-off-by: Jeremy Huddleston <jeremyhu@apple.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 90c9179e..94ec3acc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -261,7 +261,7 @@ AM_CONDITIONAL(OS2, test x$os2 = xtrue)
AC_ARG_WITH(launchd, AS_HELP_STRING([--with-launchd], [Build with support for Apple's launchd (default: auto)]), [LAUNCHD=$withval], [LAUNCHD=auto])
if test "x$LAUNCHD" = xauto; then
unset LAUNCHD
- AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no])
+ AC_CHECK_PROG(LAUNCHD, [launchd], [yes], [no], [$PATH$PATH_SEPARATOR/sbin])
fi
if test "x$LAUNCHD" = xyes ; then