summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHelmut Grohne <helmut@subdivi.de>2018-07-18 07:04:27 -0700
committerKevin Brace <kevinbrace@gmx.com>2018-07-18 07:04:27 -0700
commit11b230ba61c00c69b23c5be592cf88492113355e (patch)
tree6afff0b4b1a67fe9389970e706d290c35f8bbf63 /configure.ac
parentd87d1aac04415d74ab32e820e9e351432c66cfdb (diff)
Fix for cross build failure
configure.ac fails to cross build from source, because it abuses AC_CHECK_FILE for finding headers. AC_CHECK_FILE is supposed to find files on the host system. You cannot usually expect the host system to have headers, so this use is incorrect. It happens to also break cross compilation. Signed-off-by: Helmut Grohne <helmut@subdivi.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 20 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 2abaf52..961d974 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,14 +84,26 @@ sdkdir=`$PKG_CONFIG --variable=sdkdir xorg-server`
# Checks for libraries.
if test "$DRI" != no; then
- AC_CHECK_FILE([${sdkdir}/dri.h],
- [have_dri_h="yes"], [have_dri_h="no"])
- AC_CHECK_FILE([${sdkdir}/sarea.h],
- [have_sarea_h="yes"], [have_sarea_h="no"])
- AC_CHECK_FILE([${sdkdir}/dristruct.h],
- [have_dristruct_h="yes"], [have_dristruct_h="no"])
- AC_CHECK_FILE([${sdkdir}/damage.h],
- [have_damage_h="yes"], [have_damage_h="no"])
+ if test -f "${sdkdir}/dri.h"; then
+ have_dri_h="yes"
+ else
+ have_dri_h="no"
+ fi
+ if test -f "${sdkdir}/sarea.h"; then
+ have_sarea_h="yes"
+ else
+ have_sarea_h="no"
+ fi
+ if test -f "${sdkdir}/dristruct.h"; then
+ have_dristruct_h="yes"
+ else
+ have_dristruct_h="no"
+ fi
+ if test -f "${sdkdir}/damage.h"; then
+ have_damage_h="yes"
+ else
+ have_damage_h="no"
+ fi
fi
AC_MSG_CHECKING([whether to include DRI support])