summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:07 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-10-03 21:22:07 +0000
commitbd48e0531a16bdf27fc8549826cc1123ba12d5bd (patch)
tree44d2bcf4aae014d2688c62f9dbbb956c7bfa5016 /Makefile.am
parent6fda4e886c30669e346f7f30a38b93a77004a7f6 (diff)
- For all drivers that have a <driver>.sgml file, add code in their build
system to build the README file at make dist time - in util/macros/xorg-macros.m4, add a new XORG_CHECK_LINUXDOC macro that will check if the required tools and files exist, and if so set a conditional. - util/modular/symlink.sh - Link all the <driver>.sgml to xf86-video-<driver>/README.sgml - Add all the README.<driver> to the list of excluded files - xc/programs/Xserver/hw/xfree86/doc/sgml/SiS.sgml: Various changes to make it spew less warnings when the text file is built.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7052905f..2b6c46aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,3 +20,10 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+if BUILD_LINUXDOC
+README: README.sgml
+ $(MAKE_TEXT) README.sgml && mv README.txt README
+endif
+
+EXTRA_DIST = README.sgml