summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormallum <mallum@f5eea0f0-44ea-0310-b729-df5b855dafe5>2005-03-22 18:51:40 +0000
committermallum <mallum@f5eea0f0-44ea-0310-b729-df5b855dafe5>2005-03-22 18:51:40 +0000
commitb989a142a1cedd2691eb6b4ba23f92c4cca6c7ec (patch)
treefe08cde5de5099696c83ab81a1c5d00a74e7f738 /configure.ac
move and rename interaction -> xresponse
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d024755
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,28 @@
+AC_PREREQ(2.53)
+AC_INIT([xresponse], 0.3.1, [ross@o-hand.com])
+AC_CONFIG_SRCDIR([xresponse.c])
+
+AM_INIT_AUTOMAKE()
+
+AM_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+
+#PKG_CHECK_MODULES(X11, x11, [have_libx11pc="yes"], [have_libx11pc="no"])
+
+# Very lazy check, possibly do old way aswell, but damage will be needed
+# whatever so likely will need autoconfed ( fd.o ) xlibs.
+PKG_CHECK_MODULES(XLIBS, x11 xext xtst xdamage)
+
+AC_SUBST(XLIBS_CFLAGS)
+AC_SUBST(XLIBS_LIBS)
+
+if test "x$GCC" = "xyes"; then
+ GCC_FLAGS="-g -Wall"
+fi
+
+AC_SUBST(GCC_FLAGS)
+
+# Checks for header files.
+AC_OUTPUT([Makefile])