summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2008-10-20 14:33:23 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2008-10-20 14:33:23 -0700
commitfc0b73673a7b91b386d8a346652f9cc0c4a68d44 (patch)
tree5723b174c07b185b92ad4d16fd0500959358b566 /configure.ac
parent0de4f54967a7ab923817712eb96b64ca1ebe84a5 (diff)
Allow specifying multiple paths to --with-cpp and running if none is found
Merge of code from the old Solaris xrdb that allows having cpp found at compile time, but not erroring out if it's not found at runtime, and if necessary, checking for it in multiple locations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 77d56ec..6348b55 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,12 +66,13 @@ fi
# in Imake config files for each OS
AC_ARG_WITH([cpp],
AC_HELP_STRING([--with-cpp=path],
- [path to cpp command for xrdb to use at runtime]),
+ [comma-separated list of paths to cpp command for xrdb to use at runtime]),
[AC_MSG_CHECKING(for cpp)
CPP_PATH=$withval
- AC_MSG_RESULT($CPP_PATH)],
+ AC_MSG_RESULT(--with-cpp specified $CPP_PATH)],
[AC_PATH_PROG([CPP_PATH],[cpp], [cpp],
[$PATH:/bin:/usr/bin:/usr/lib:/usr/libexec:/usr/ccs/lib:/usr/ccs/lbin:/lib])])
+CPP_PATH=`echo ${CPP_PATH} | sed 's/,/\\",\\"/g'`
AC_DEFINE_UNQUOTED([CPP], "$CPP_PATH", [Path to CPP program])
# Checks for pkg-config packages