summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-12-08 17:55:17 +0000
committerKevin E Martin <kem@kem.org>2005-12-08 17:55:17 +0000
commit9b949814b988ffb0d01bfd945b207bbb8379e573 (patch)
tree9b577832e4e8ce0084e8efecfaa4fef6dfa6e0aa /configure.ac
parent6f19ff5947590d28e17fd86a47af38f2d3abf90d (diff)
Add configure options to allow hard-coded paths to be changed.MODULAR_COPY
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9b91b89..e6c530b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,6 +34,13 @@ AC_CANONICAL_HOST
AC_CHECK_LIB(z, gzopen,, AC_MSG_ERROR([zlib not found]))
+AC_ARG_WITH(localealiasfile,
+ AC_HELP_STRING([--with-localealiasfile=<path>],
+ [The locale alias file (default: ${libdir}/X11/locale/locale.alias)]),
+ [LOCALEALIASFILE="$withval"],
+ [LOCALEALIASFILE=${libdir}/X11/locale/locale.alias])
+AC_SUBST([LOCALEALIASFILE])
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(LUIT, x11 fontenc)