summaryrefslogtreecommitdiff
path: root/doc/doxygen/xml/Client/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'doc/doxygen/xml/Client/meson.build')
-rw-r--r--doc/doxygen/xml/Client/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/doc/doxygen/xml/Client/meson.build b/doc/doxygen/xml/Client/meson.build
new file mode 100644
index 0000000..849c30d
--- /dev/null
+++ b/doc/doxygen/xml/Client/meson.build
@@ -0,0 +1,18 @@
+tgt = custom_target(
+ 'xml-Client-doc',
+ command: [
+ gen_doxygen,
+ # XXX pass doxygen path as argument
+ '--builddir=@OUTDIR@',
+ '--section=Client',
+ '--output-format=xml',
+ wayland_doxygen,
+ '@INPUT@',
+ ],
+ input: [ shared_files, client_files ],
+ output: [ 'combine.xslt', 'index.xml' ],
+ depends: [dot_png, dot_map]
+)
+
+doxygen_Client_combine_xslt = tgt[0]
+doxygen_Client_index_xml = tgt[1]