summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index f676bf4..dbe6724 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -1,6 +1,7 @@
## Process this file with automake to produce Makefile.in
AM_CPPFLAGS = \
+ $(PIE_CFLAGS) \
-DUP_COMPILATION \
-DG_LOG_DOMAIN=\"UPower\" \
-I$(top_srcdir) \
@@ -20,7 +21,9 @@ upower_SOURCES = \
upower_CPPFLAGS = \
$(AM_CPPFLAGS)
-upower_LDFLAGS = -pthread
+upower_LDFLAGS =
+ -pthread \
+ $(PIE_LDFLAGS)
upower_LDADD = \
$(DBUS_GLIB_LIBS) \