summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2010-05-18 09:37:17 +0100
committerRichard Hughes <richard@hughsie.com>2010-05-18 09:37:17 +0100
commit2b826a316954eec9951b9bf98b853560cfd70828 (patch)
treecb912f753a21f547c36f0e4bc5eb8564b49d0d75 /configure.ac
parent39c2c0c52ceb0585907282f2a9b0232fdd926903 (diff)
Port UPower to libusb1 to avoid crappy unfixable crashes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index ce57c71..fa03cfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,12 +180,7 @@ AC_SUBST(BACKEND, "$with_backend")
# only need GUdev on linux
if test x$with_backend = xlinux; then
PKG_CHECK_MODULES(GUDEV, [gudev-1.0 >= 001])
- AC_SUBST(GUDEV_CFLAGS)
- AC_SUBST(GUDEV_LIBS)
-
- dnl Check libusb also
- AC_CHECK_HEADERS(usb.h, , [AC_MSG_ERROR([Can't find usb.h. Please install libusb.])])
- AC_CHECK_LIB([usb], [usb_find_devices], [], [AC_MSG_ERROR([Can't use libusb.])])
+ PKG_CHECK_MODULES(USB, [libusb-1.0 >= 1.0.0])
fi
# export to Makefile.am