summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <hughsie@hughsie-rawhide2.(none)>2009-07-27 17:15:27 +0100
committerRichard Hughes <hughsie@hughsie-rawhide2.(none)>2009-07-27 17:15:27 +0100
commit90501fc1ea8b725ab0e2685a91c519ca5ce18eea (patch)
tree05c28c8bf6ef77dd5a90889954af01822be2cfbe /configure.ac
parent0c8d29a90f5b5b7d84ec834213ac7e4390e89db9 (diff)
Actually make compile with the linux backend
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5189ecf..38cc79f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,7 +170,7 @@ AC_ARG_WITH([backend],
[Default backend to use linux, dummy (dummy)]))
# default to a sane option
if test x$with_backend = x; then
- if test -e /usr/include/libudev.h ; then
+ if test -e /usr/include/gudev-1.0/gudev/gudev.h ; then
with_backend=linux
else
with_backend=dummy
@@ -190,6 +190,10 @@ if test x$with_backend = xlinux; then
AC_CHECK_LIB([usb], [usb_find_devices], [], [AC_MSG_ERROR([Can't use libusb.])])
fi
+# export to Makefile.am
+AM_CONDITIONAL(BACKEND_TYPE_DUMMY, [test x$with_backend = xdummy])
+AM_CONDITIONAL(BACKEND_TYPE_LINUX, [test x$with_backend = xlinux])
+
if test "x$GCC" = "xyes"; then
LDFLAGS="-Wl,--as-needed $LDFLAGS"
fi