summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2009-07-06 10:13:02 +0100
committerRichard Hughes <richard@hughsie.com>2009-07-06 10:13:02 +0100
commit161d2d50c1fd04d6b184cc6c6c13a65ae97328ca (patch)
tree22f5b92b923edd73d45f6aac17825f3c7b00b2f6 /configure.ac
parentff42e21d331ca21e5bfd225920a774bf348a53ab (diff)
parent86f6278f61d30e6ca97bdf421299d156b6607fda (diff)
Fix conflicts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3573ecc..5508c62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,6 +6,12 @@ AM_INIT_AUTOMAKE(DeviceKit-power, 009)
AM_CONFIG_HEADER(config.h)
AM_MAINTAINER_MODE
+# enable nice build output on automake1.11
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+
+# use this in dkp-version.h
+AC_SUBST(VERSION)
+
# libtool versioning - this applies to devkit-power-gobject
#
# See http://sources.redhat.com/autobook/autobook/autobook_91.html#SEC91 for details
@@ -50,6 +56,14 @@ AM_CONDITIONAL(MAN_PAGES_ENABLED, test x$enable_man_pages = xyes)
GTK_DOC_CHECK([1.3])
+# udev rules go in /lib, not /usr/lib
+if test "$prefix" = "/usr" -o "$prefix" = "/usr/local" ; then
+ slashlibdir=/lib
+else
+ slashlibdir=$prefix/lib
+fi
+AC_SUBST(slashlibdir)
+
#### gcc warning flags
dnl ---------------------------------------------------------------------------
@@ -175,7 +189,9 @@ doc/version.xml
doc/man/Makefile
doc/dbus/Makefile
policy/Makefile
+rules/Makefile
devkit-power-gobject/Makefile
+devkit-power-gobject/dkp-version.h
po/Makefile.in
])