summaryrefslogtreecommitdiff
path: root/SpiceXPI/Makefile.am
diff options
context:
space:
mode:
authorChristophe Fergeau <cfergeau@redhat.com>2013-04-17 13:22:14 +0200
committerChristophe Fergeau <cfergeau@redhat.com>2013-04-17 13:23:45 +0200
commit13889e35ab10f577e83a20a88697ef2581ab3469 (patch)
tree160e3b6c9f331df6a5ba6c0e3604816ddfd811f0 /SpiceXPI/Makefile.am
parentd55537c24f73deca0346ab37d93bf5d4437f77b5 (diff)
build: Adjust plugin name when building xpi
The plugin binary name was changed from libnsISpice to npSpiceConsole, but the Makefile.am rule optionnally building SpiceXpi.xpi was not changed to take this rename into account.
Diffstat (limited to 'SpiceXPI/Makefile.am')
-rw-r--r--SpiceXPI/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/SpiceXPI/Makefile.am b/SpiceXPI/Makefile.am
index de058b5..a12135a 100644
--- a/SpiceXPI/Makefile.am
+++ b/SpiceXPI/Makefile.am
@@ -9,12 +9,12 @@ all-local: SpiceXPI.xpi
CLEANFILES = SpiceXPI.xpi
-SpiceXPI.xpi: $(srcdir)/src/install.rdf src/plugin/nsISpicec.xpt src/plugin/.libs/libnsISpicec.so
+SpiceXPI.xpi: $(srcdir)/src/install.rdf src/plugin/nsISpicec.xpt src/plugin/.libs/npSpiceConsole.so
$(AM_V_GEN)rm -rf $(DISTDIR)
@[ -d $(DISTDIR)/plugins ] || mkdir -p $(DISTDIR)/plugins
@cp $(srcdir)/src/install.rdf $(DISTDIR)
@cp src/plugin/*.xpt $(DISTDIR)/plugins
- @cp src/plugin/.libs/libnsISpicec.so $(DISTDIR)/plugins/nsISpicec.so
+ @cp src/plugin/.libs/npSpiceConsole.so $(DISTDIR)/plugins/npSpiceConsole.so
@(cd $(DISTDIR); zip -q -r ../$@ .)
distclean-local: