summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlos Garcia Campos <carlosgc@gnome.org>2011-02-13 16:21:52 +0100
committerCarlos Garcia Campos <carlosgc@gnome.org>2011-02-13 16:24:53 +0100
commit675b3505f963a0110dac7f865654232cbb865ef5 (patch)
treee937c2fefa4c8c2d83af91bd8472d47d2a715552 /test/CMakeLists.txt
parent728c022cdc1ea12aa54077d44276f9d7714930d4 (diff)
tests: Merge splash and cairo tests into a single gtk-test tool
With a command line option to use cairo or splash backends.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt20
1 files changed, 5 insertions, 15 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index acb867be..cff715c2 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -24,24 +24,14 @@ if (GTK_FOUND)
${CMAKE_BINARY_DIR}/glib
)
- if (ENABLE_SPLASH)
-
- set (gtk_splash_test_SRCS
- gtk-splash-test.cc
- )
- poppler_add_test(gtk-splash-test BUILD_GTK_TESTS ${gtk_splash_test_SRCS})
- target_link_libraries(gtk-splash-test poppler ${GTK2_LIBRARIES})
-
- endif (ENABLE_SPLASH)
+ set (gtk_splash_test_SRCS
+ gtk-test.cc
+ )
+ poppler_add_test(gtk-test BUILD_GTK_TESTS ${gtk_splash_test_SRCS})
+ target_link_libraries(gtk-test poppler-glib ${GTK2_LIBRARIES})
if (HAVE_CAIRO)
- set (gtk_cairo_test_SRCS
- gtk-cairo-test.cc
- )
- poppler_add_test(gtk-cairo-test BUILD_GTK_TESTS ${gtk_cairo_test_SRCS})
- target_link_libraries(gtk-cairo-test poppler-glib ${GTK2_LIBRARIES})
-
set (pdf_inspector_SRCS
pdf-inspector.cc
)