summaryrefslogtreecommitdiff
path: root/glib/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <aacid@kde.org>2018-01-08 22:55:00 +0100
committerAlbert Astals Cid <aacid@kde.org>2018-01-08 22:55:00 +0100
commite428033c2d7efbbbf89bb2f84c8998521ac7ef8e (patch)
tree546f48df418659224c4500adc01fcddb4d9384a9 /glib/CMakeLists.txt
parent2e47887616155dee566083e1aac9adab69aa4386 (diff)
Run clang-tidy with modernize nullptr
Also add two enum values in the qt5 frontend to representate no flags Also mark glib/gtk/cairo system includes so that gcc doesn't report the issues in those headers
Diffstat (limited to 'glib/CMakeLists.txt')
-rw-r--r--glib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
index e089ef8e..9a09d7ab 100644
--- a/glib/CMakeLists.txt
+++ b/glib/CMakeLists.txt
@@ -1,6 +1,10 @@
include_directories(
${CMAKE_CURRENT_SOURCE_DIR}
${CMAKE_CURRENT_BINARY_DIR}
+)
+
+include_directories(
+ SYSTEM
${GLIB2_INCLUDE_DIRS}
${CAIRO_INCLUDE_DIRS}
)