summaryrefslogtreecommitdiff
path: root/glib/CMakeLists.txt
diff options
context:
space:
mode:
authorPino Toscano <pino@kde.org>2012-11-26 14:44:21 +0100
committerPino Toscano <pino@kde.org>2012-11-26 14:44:21 +0100
commitdcbc9686d97f4f6596c43d1f701207278c25f8eb (patch)
tree0b98c7493d1e272af7892265d9da1f6f75692c6c /glib/CMakeLists.txt
parent169e4cb001fa235ca608d3d0b42ea4214161fc2d (diff)
glib/cmake: Include Gio-2.0 for introspection
Fixes g-ir-scanner warnings: poppler-document.cc:257: Warning: Poppler: poppler_document_new_from_stream: argument stream: Unresolved type: 'GInputStream*' poppler-document.cc:257: Warning: Poppler: poppler_document_new_from_stream: argument cancellable: Unresolved type: 'GCancellable*' poppler-document.cc:315: Warning: Poppler: poppler_document_new_from_gfile: argument file: Unresolved type: 'GFile*' poppler-document.cc:315: Warning: Poppler: poppler_document_new_from_gfile: argument cancellable: Unresolved type: 'GCancellable*' https://bugs.freedesktop.org/show_bug.cgi?id=56218 folloup of c84753e12029fcc6113f80dedc9a943ce1deb214
Diffstat (limited to 'glib/CMakeLists.txt')
-rw-r--r--glib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/glib/CMakeLists.txt b/glib/CMakeLists.txt
index 4d71ed29..b07b3580 100644
--- a/glib/CMakeLists.txt
+++ b/glib/CMakeLists.txt
@@ -110,7 +110,7 @@ if (HAVE_INTROSPECTION)
set(introspection_files ${poppler_glib_SRCS} ${poppler_glib_public_headers})
set(Poppler_0_18_gir "poppler-glib")
- set(Poppler_0_18_gir_INCLUDES GObject-2.0 cairo-1.0)
+ set(Poppler_0_18_gir_INCLUDES GObject-2.0 Gio-2.0 cairo-1.0)
get_directory_property(_tmp_includes INCLUDE_DIRECTORIES)
_list_prefix(_includes _tmp_includes "-I")
set(Poppler_0_18_gir_CFLAGS ${_includes})