summaryrefslogtreecommitdiff
path: root/cpp/Makefile.am
diff options
context:
space:
mode:
authorHib Eris <hib@hiberis.nl>2010-03-02 16:33:04 +0100
committerPino Toscano <pino@kde.org>2010-03-02 22:19:08 +0100
commit690af1bc58de1ebe710c5e599f1cb635e4838fc8 (patch)
treed09487ef570b899d6c7f2a113b499341113e105a /cpp/Makefile.am
parent7492a376e7e5ec35534276ac15485123645617b0 (diff)
[cpp] define poppler_cpp_EXPORTS when building with autotools as well
fixes building on Windows
Diffstat (limited to 'cpp/Makefile.am')
-rw-r--r--cpp/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpp/Makefile.am b/cpp/Makefile.am
index f19428e3..d8891db0 100644
--- a/cpp/Makefile.am
+++ b/cpp/Makefile.am
@@ -35,6 +35,9 @@ libpoppler_cpp_la_SOURCES = \
poppler-toc-private.h \
poppler-version.cpp
+libpoppler_cpp_la_CXXFLAGS = \
+ -Dpoppler_cpp_EXPORTS
+
libpoppler_cpp_la_LIBADD = \
$(top_builddir)/poppler/libpoppler.la \
$(LIBICONV)