summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Toomey <poppler@tuhs.org>2009-01-06 01:16:31 +0100
committerAlbert Astals Cid <aacid@kde.org>2009-01-06 01:18:59 +0100
commitdfba6c022b150553cb2b18b027e661b3b4625ce7 (patch)
tree3969d77d0ba96bb856b1efe2215ec98393653949 /configure.ac
parent0963c276ba972a36c2895e4fe1c7475acd489738 (diff)
Make pdftohtml output png images when the image stream is not a jpeg
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 96ebe8d5..010b77ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -180,6 +180,19 @@ AM_CONDITIONAL(BUILD_LIBJPEG, test x$enable_libjpeg = xyes)
AH_TEMPLATE([ENABLE_LIBJPEG],
[Use libjpeg instead of builtin jpeg decoder.])
+dnl Test for libpng
+AC_ARG_ENABLE(libpng,
+ AC_HELP_STRING([--disable-libpng],
+ [Don't build against libpng.]),
+ enable_libpng=$enableval,
+ enable_libpng="try")
+if test x$enable_libpng != xno; then
+ POPPLER_FIND_PNG
+fi
+
+AM_CONDITIONAL(BUILD_LIBPNG, test x$enable_libpng = xyes)
+AH_TEMPLATE([ENABLE_LIBPNG],
+ [Build against libpng.])
dnl Check for freetype headers
FREETYPE_LIBS=
@@ -493,6 +506,7 @@ echo " glib wrapper: $enable_poppler_glib"
echo " use GDK: $enable_gdk"
echo " use gtk-doc: $enable_gtk_doc"
echo " use libjpeg: $enable_libjpeg"
+echo " use libpng: $enable_libpng"
echo " use zlib: $enable_zlib"
echo " use libopenjpeg: $enable_libopenjpeg"
echo " command line utils: $enable_utils"