summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Ewins <Brian.Ewins@gmail.com>2009-03-09 22:54:58 +0100
committerAlbert Astals Cid <aacid@kde.org>2009-03-09 22:56:12 +0100
commit7a5d1e57b2757c986da17f7238415b927e73127f (patch)
tree1eb928c34f2fa65615faa3a46f5d34fd38799eee /configure.ac
parent8dc9e4d57a4759de2b56a87d9bace80d5d563fef (diff)
Check for pkgconfig before using it
At the moment if pkgconfig is not installed, an unhelpful syntax error appears when testing for freetype. Identify the problem earlier on
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3b919c54..d32f0482 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,12 @@ AC_PROG_INSTALL
AC_CHECK_FUNC(gettimeofday, AC_DEFINE(HAVE_GETTIMEOFDAY, 1, [Defines if gettimeofday is available on your system]))
AC_CHECK_FUNC(localtime_r, AC_DEFINE(HAVE_LOCALTIME_R, 1, [Defines if localtime_r is available on your system]))
+dnl ##### Check for pkgconfig
+AC_CHECK_PROG(HAVE_PKGCONFIG, pkg-config, yes, no)
+if test "x$HAVE_PKGCONFIG" = "xno"; then
+ AC_MSG_ERROR("*** pkg-config not found ***")
+fi
+
dnl Enable these unconditionally.
AC_DEFINE([OPI_SUPPORT], [1], [Generate OPI comments in PS output.])
AC_DEFINE([MULTITHREADED], [1], [Enable multithreading support.])