summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKristian Høgsberg <krh@redhat.com>2005-06-02 18:49:55 +0000
committerKristian Høgsberg <krh@redhat.com>2005-06-02 18:49:55 +0000
commit47c3b4ec2c7691e44f5100b1f5956df0005467c8 (patch)
treeeece83c09cf9d1d82afa832e009ab6af5a796d8f /configure.ac
parent9f0da96dd005defd5d82dd05b627ff1925430215 (diff)
2005-06-02 Kristian Høgsberg <krh@redhat.com>
Patch from Stanislav Brabec <sbrabec@suse.cz>: * configure.ac: * poppler-cairo.pc.in: * poppler-glib.pc.in: * poppler-qt.pc.in: * poppler-splash.pc.in: Misc fixes to pkg-config files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 31baef68..d3946a8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,15 +175,17 @@ if test x$enable_splash_output = xyes; then
AC_DEFINE(HAVE_SPLASH)
fi
+CAIRO_VERSION="0.5"
+AC_SUBST(CAIRO_VERSION)
AC_ARG_ENABLE(cairo-output,
AC_HELP_STRING([--disable-cairo-output],
[Don't build the cairo graphics backend.]),
enable_cairo_output=$enableval,
enable_cairo_output="try")
if test x$enable_cairo_output = xyes; then
- PKG_CHECK_MODULES(CAIRO, cairo >= 0.5.0 fontconfig)
+ PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_VERSION fontconfig)
elif test x$enable_cairo_output = xtry; then
- PKG_CHECK_MODULES(CAIRO, cairo >= 0.5.0 fontconfig,
+ PKG_CHECK_MODULES(CAIRO, cairo >= $CAIRO_VERSION fontconfig,
[enable_cairo_output="yes"],
[enable_cairo_output="no"])
fi