summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlbert Astals Cid <aacid@kde.org>2008-06-14 01:24:49 +0200
committerAlbert Astals Cid <aacid@kde.org>2008-06-14 01:24:49 +0200
commit2affed0fc97b958ae46f531c471a3cf0b04c0f55 (patch)
tree79860544cbf834ca23f13634dd8c86f2407c5a40 /configure.ac
parent8e74bc612cb4102891324ffdbfcdb47293ecb95e (diff)
Give warnings if the build configuration for stream decoders is different from default one
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 17 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 05dfdb04..aa3b9321 100644
--- a/configure.ac
+++ b/configure.ac
@@ -446,9 +446,6 @@ echo ""
echo "Building poppler with support for:"
echo " splash output: $enable_splash_output"
echo " cairo output: $enable_cairo_output"
-if test x$enable_splash_output = xno -a x$enable_cairo_output = xno; then
- echo " Warning: There is no rendering backend enabled"
-fi
echo " abiword output: $enable_abiword_output"
echo " qt wrapper: $enable_poppler_qt"
echo " qt4 wrapper: $enable_poppler_qt4"
@@ -459,3 +456,20 @@ echo " use libjpeg: $enable_libjpeg"
echo " use zlib: $enable_zlib"
echo " use libopenjpeg: $enable_libopenjpeg"
echo " command line utils: $enable_utils"
+echo ""
+
+if test x$enable_splash_output = xno -a x$enable_cairo_output = xno; then
+ echo " Warning: There is no rendering backend enabled"
+fi
+
+if test x$enable_libjpeg != xyes; then
+ echo " Warning: Using libjpeg is recommended"
+fi
+
+if test x$enable_zlib != xno; then
+ echo " Warning: Using zlib is not totally safe"
+fi
+
+if test x$enable_libopenjpeg != xyes; then
+ echo " Warning: Using libopenjpeg is recommended"
+fi