summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAdrian Johnson <ajohnson@redneon.com>2017-11-12 10:33:07 +1030
committerAdrian Johnson <ajohnson@redneon.com>2017-11-15 18:14:58 +1030
commit5c394f71f03d27507db3446ad34f299393fa3621 (patch)
treee37a6263c89eaa42a0fd5179a264900cdbbfcb8e /CMakeLists.txt
parent9ff60568ab420e86295bfa81cef9375d7c5600b8 (diff)
Move UTF8.h to UnicodeMapFuncs.h and rename UCS2 to UTF16
UTF8.h is not exclusively UTF-8 code. Renaming to UnicodeMapFuncs.h identifies the file as containing maps for UnicodeMap and is consistent with the name UnicodeMapTables.h. The mapUCS2 code was changed to support UTF-16 in 979ef1ca without changing the name.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f181fdec..3a34168f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,6 +610,7 @@ if(ENABLE_XPDF_HEADERS)
poppler/StructElement.h
poppler/StructTreeRoot.h
poppler/UnicodeMap.h
+ poppler/UnicodeMapFuncs.h
poppler/UnicodeMapTables.h
poppler/UnicodeTypeTable.h
poppler/UnicodeCClassTables.h
@@ -627,7 +628,6 @@ if(ENABLE_XPDF_HEADERS)
poppler/StdinCachedFile.h
poppler/StdinPDFDocBuilder.h
poppler/UTF.h
- poppler/UTF8.h
poppler/XpdfPluginAPI.h
poppler/Sound.h
${CMAKE_CURRENT_BINARY_DIR}/poppler/poppler-config.h