summaryrefslogtreecommitdiff
path: root/pm/Makefile.am
diff options
context:
space:
mode:
authorVictor Lowther <victor.lowther@gmail.com>2008-02-02 12:39:57 -0600
committerVictor Lowther <victor.lowther@gmail.com>2008-02-02 12:39:57 -0600
commit349c2e5a0c7ab1c81be31eeae2d633935d1823a2 (patch)
tree814f3080065923fbbfca0675b825a1e4b095467b /pm/Makefile.am
parenta50dc9e1dd0b267cbc67eb34913d2f427a618671 (diff)
Use autotools to make functions location-independent.
Diffstat (limited to 'pm/Makefile.am')
-rw-r--r--pm/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/pm/Makefile.am b/pm/Makefile.am
index 9b13c34..e064ac0 100644
--- a/pm/Makefile.am
+++ b/pm/Makefile.am
@@ -1,11 +1,14 @@
SUBDIRS = sleep.d power.d
extradir = $(libdir)/pm-utils
+pm_sysconfdir = $(sysconfdir)/pm
extra_SCRIPTS = \
functions \
defaults
+CLEANFILES = functions
+
EXTRA_DIST = \
$(extra_SCRIPTS)
@@ -13,7 +16,7 @@ install-exec-local:
-mkdir $(DESTDIR)$(sysconfdir)/pm/config.d
do_subst = sed -e 's,[@]PM-UTILS-LIBDIR[@],$(extradir),g' \
- -e 's,[@]PM-UTILS-SYSCONFDIR[@],$(sysconfdir),g'
+ -e 's,[@]PM-UTILS-SYSCONFDIR[@],$(pm_sysconfdir),g'
SUFFIXES = .in