summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2008-05-10 18:36:18 +0200
committerMichael Biebl <mbiebl@gmail.com>2008-05-10 18:36:18 +0200
commit2ceff51a323d13ab9b8df1a0b6db46b436d8e053 (patch)
treed1e78f8d0a532c3067e72028d26bc11156dcd155 /man/Makefile.am
parent8cff1174e991e21283032439ca972a6b4005c91f (diff)
Create man pages from docbook xml
- Remove old docbook2man rules. - Add rules for creating man pages from docbook xml using xmlto.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am32
1 files changed, 16 insertions, 16 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 376a714..5b17379 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,26 +1,26 @@
-pm_mans = \
- on_ac_power.1 \
- pm-pmu.1
-
-if HAVE_DOCBOOK
man_MANS = \
- $(pm_mans)
-endif
+ on_ac_power.1 \
+ pm-pmu.1 \
+ pm-is-supported.1 \
+ pm-powersave.8 \
+ pm-action.8
EXTRA_DIST = \
- on_ac_power.sgml \
- pm-pmu.sgml \
- $(pm_mans)
+ on_ac_power.xml \
+ pm-pmu.xml \
+ pm-is-supported.xml \
+ pm-powersave.xml \
+ pm-action.xml \
+ $(man_MANS)
MAINTAINERCLEANFILES = \
- $(pm_mans)
+ $(man_MANS)
-pm-pmu.1: pm-pmu.sgml
- $(DOCBOOK2MAN) $?
+.xml.1:
+ $(XMLTO) man $?
-on_ac_power.1: on_ac_power.sgml
- $(DOCBOOK2MAN) $?
+.xml.8:
+ $(XMLTO) man $?
clean-local :
rm -f *~
- rm -f manpage.*