summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2005-07-14 13:05:20 +0000
committerArch Librarian <arch@canonical.com>2005-07-14 13:05:20 +0000
commitd793148d0690c72dfdd7f024028edb229ad1b4bf (patch)
tree4ee596e3b35998cecea7e1b1d861986eff78e1ad /Makefile.am
parentd2c6c3cccbb9381d4cf030e4ac2d5a63dc3c4c79 (diff)
2002-09-13 Tor Lillqvist <tml@iki.fi>
Author: tml Date: 2002-09-12 20:47:07 GMT 2002-09-13 Tor Lillqvist <tml@iki.fi> * Makefile.am (USE_INSTALLED_GLIB): Seems that the automake version used by Havoc doesn't recognize pkg_config_CFLAGS and pkg_config_LDFLAGS, thus failing builds on Win32 directly from the tarball. Set included_glib_includes and pkg_config_LDADD instead, then, like in the !USE_INSTALLED_GLIB branch. * findme.c (X_OK): If X_OK undefined, define as 1, always, not only if G_OS_WIN32, which is never defined here. Fixes a corner case on Win32 with MSYS and mingw where configure as included in the release tarball for some reason doesn't find unistd.h.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7368e8a..18a597e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
if USE_INSTALLED_GLIB
-pkg_config_CFLAGS = @GLIB_CFLAGS@
-pkg_config_LDFLAGS = @GLIB_LIBS@
+included_glib_includes = @GLIB_CFLAGS@
+pkg_config_LDADD=@GLIB_LIBS@
else
SUBDIRS = glib-1.2.8
included_glib_includes = -I./glib-1.2.8