summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorArch Librarian <arch@canonical.com>2005-07-14 13:04:29 +0000
committerArch Librarian <arch@canonical.com>2005-07-14 13:04:29 +0000
commit1aaee14cab6ed427fe6c8610d1eb60e66c861318 (patch)
treef2073063c2e99ef75e90085278a302edc66fd0d5 /Makefile.am
parent5f14bf25e56fda6e38a7dfc153378543c625257f (diff)
2001-09-30 Tor Lillqvist <tml@iki.fi>
Author: tml Date: 2001-09-29 21:05:25 GMT 2001-09-30 Tor Lillqvist <tml@iki.fi> Changes for "pure" Win32 (without Cygwin or similar) support. The most important differences compared to pkg-config on Unix are: We don't use hardcoded PKGLIBDIR paths but deduce the installation prefix at runtime. Use the normal GLib DLL, not a private copy. Yes, this does introduce a circular dependency, but that can be worked around. * README.win32: New file. * configure.in: Check for Win32. If so, define USE_INSTALLED_GLIB, and don't configure in the included glib-1.2.8. Set GLIB_CFLAGS and GLIB_LIBS assuming that GLib is installed in the same location pkgconfig will be. Check for dirent.h, unistd.h and sys/wait.h headers. * Makefile.am: If USE_INSTALLED_GLIB, use the GLIB_* values set above, and don't make in the glib-1.2.8 subdir. * autogen.sh: Use perl -p -i.bak, works better on Win32 (and Cygwin). * *.c: Conditionalize inclusions of unistd.h and sys/wait.h. * findme.c: Define X_OK on Win32 if necessary. * parse.c * popthelp.c: Minor Win32 portability ifdefs. * parse.c: No need to include <windows.h>. * pkg.c: Don't hardcode PKGLIBDIR, but use g_win32_get_package_installation_directory() to deduce it. (scan_dir): Make a temp copy of dirname with potential superfluous trailing slash removed. The Win32 opendir implementation doesn't always like those. * pkg.h: If USE_INSTALLED_GLIB, include <glib.h> instead of partial-glib.h. * popt.c (execCommand): Don't compile on Win32. * poptconfig.c (configLine): Don't bother with the "exec" stuff on Win32, too complex to port, at least for now. (poptReadDefaultConfig) Don't bother compiling on Win32, this function isn't even called.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 68e0118..8abe8f4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,11 @@
+if USE_INSTALLED_GLIB
+pkg_config_CFLAGS = @GLIB_CFLAGS@
+pkg_config_LDFLAGS = @GLIB_LIBS@
+else
SUBDIRS = glib-1.2.8
+included_glib_includes = -I./glib-1.2.8
+pkg_config_LDADD=glib-1.2.8/libglib.la
+endif
m4dir = $(datadir)/aclocal
m4_DATA = pkg.m4
@@ -8,7 +15,7 @@ EXTRA_DIST = $(m4_DATA) $(man_MANS)
bin_PROGRAMS = pkg-config
-INCLUDES=-DPKGLIBDIR="\"$(pkglibdir)\"" -I./glib-1.2.8
+INCLUDES=-DPKGLIBDIR="\"$(pkglibdir)\"" $(included_glib_includes)
pkg_config_SOURCES= \
pkg.h \
@@ -27,4 +34,3 @@ pkg_config_SOURCES= \
poptint.h \
poptparse.c
-pkg_config_LDADD=glib-1.2.8/libglib.la