summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorChris Lamb <lamby@debian.org>2016-12-21 20:25:57 -0800
committerKevin Brace <kevinbrace@gmx.com>2016-12-21 20:25:57 -0800
commit25ba0a409bf0676039b42aca2226acd8af64e9f6 (patch)
tree537cf7ab56051213126cfe479e5fb3ae1aef5fc3 /src/Makefile.am
parent62de0cfac2cd5db74ea0a6ab61066d48af95b027 (diff)
Altering the compilation build script to make it reproducible.
Signed-off-by: Chris Lamb <lamby@debian.org> Reviewed-by: Dylan Aïssi <bob.dybian@gmail.com> Acked-by: Kevin Brace <kevinbrace@gmx.com>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 1eb879c..86061b2 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -116,6 +116,9 @@ version.h: $(openchrome_drv_la_SOURCES)
if [ -d .svn ]; then \
echo '#define BUILDCOMMENT "(development build, at revision '\
"`svnversion -nc .. | sed -e s/^[^:]*://`"')"' > $@.tmp; \
+ elif [ "$$SOURCE_DATE_EPOCH" ]; then \
+ printf '#define BUILDCOMMENT "(compiled with SOURCE_DATE_EPOCH: %s)"' $$SOURCE_DATE_EPOCH \
+ > $@.tmp; \
else \
date +'#define BUILDCOMMENT "(development build, compiled on %c)"' \
> $@.tmp; \