summaryrefslogtreecommitdiff
path: root/tests/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/glx/Makefile.am')
-rw-r--r--tests/glx/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/glx/Makefile.am b/tests/glx/Makefile.am
index cdebf5d0cb1..b5cc0b001ab 100644
--- a/tests/glx/Makefile.am
+++ b/tests/glx/Makefile.am
@@ -3,7 +3,6 @@ AM_CFLAGS = -I$(top_builddir)/src/glx -I$(top_builddir)/src/mapi \
AM_CXXFLAGS = -I$(top_builddir)/src/glx -I$(top_builddir)/src/mapi \
$(X11_CFLAGS) $(GTEST_CFLAGS)
-if HAVE_GTEST
if HAVE_XCB_GLX_CREATE_CONTEXT
TESTS = glx_unittest
check_PROGRAMS = glx_unittest
@@ -13,6 +12,9 @@ glx_unittest_SOURCES = \
create_context_unittest.cpp \
fake_glx_screen.cpp
-glx_unittest_LDADD = $(top_builddir)/src/glx/libglx.a $(GTEST_LIBS) -lgtest_main
-endif
+glx_unittest_LDADD = \
+ $(top_builddir)/src/glx/libglx.la \
+ $(top_builddir)/src/gtest/libgtest.la \
+ -lpthread
+
endif