summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index aa72523c0a5..6f851e25c1c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,7 +172,14 @@ esac
dnl Add flags for gcc and g++
if test "x$GCC" = xyes; then
- CFLAGS="$CFLAGS -Wall -std=c99"
+ case "$host_os" in
+ cygwin*)
+ CFLAGS="$CFLAGS -Wall -std=gnu99"
+ ;;
+ *)
+ CFLAGS="$CFLAGS -Wall -std=c99"
+ ;;
+ esac
# Enable -Werror=implicit-function-declaration and
# -Werror=missing-prototypes, if available, or otherwise, just