summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dc9272d3016..36197d3396a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,8 +286,8 @@ if test "x$GCC" = xyes; then
# Work around aliasing bugs - developers should comment this out
CFLAGS="$CFLAGS -fno-strict-aliasing"
- # We don't want floating-point math functions to set errno
- CFLAGS="$CFLAGS -fno-math-errno"
+ # We don't want floating-point math functions to set errno or trap
+ CFLAGS="$CFLAGS -fno-math-errno -fno-trapping-math"
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052