summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f338e20c7e5..70599e1d33e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,13 +56,9 @@ AC_PROG_MKDIR_P
LT_PREREQ([2.2])
LT_INIT([disable-static])
-AC_PROG_YACC
-AC_PATH_PROG([YACC_INST], $YACC)
-if test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"; then
- if test -z "$YACC_INST"; then
- AC_MSG_ERROR([yacc not found - unable to compile glcpp-parse.y])
- fi
-fi
+AX_PROG_BISON([],
+ AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"]
+ [AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))
AC_PROG_LEX
AC_PATH_PROG([PERL], [perl])