summaryrefslogtreecommitdiff
path: root/src/mesa/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-06-07 10:58:06 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-06-13 10:06:25 -0700
commite26af221438f77d8b81f956a56bc9e520f28236a (patch)
tree580687370340de3068977160ce3232b6b70a98ca /src/mesa/meson.build
parent6eaa01368554b57081254ffd473a55199993b98d (diff)
meson: Add support for SPARC assembly
This was blindly copied from autotools and tested by a helpful gentoo user. Signed-off-by: Dylan Baker <dylan.c.baker@intel.com> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/mesa/meson.build')
-rw-r--r--src/mesa/meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/mesa/meson.build b/src/mesa/meson.build
index 24b5cc821cc..8fb7db215c8 100644
--- a/src/mesa/meson.build
+++ b/src/mesa/meson.build
@@ -649,8 +649,14 @@ if with_asm_arch == 'x86'
elif with_asm_arch == 'x86_64'
files_libmesa_common += files('x86-64/x86-64.h', 'x86-64/xform4.S')
inc_libmesa_asm = include_directories('x86-64')
+elif with_asm_arch == 'sparc'
+ files_libmesa_common += files(
+ 'sparc/sparc_clip.S',
+ 'sparc/norm.S',
+ 'sparc/xform.S',
+ )
+ inc_libmesa_asm = include_directories('sparc')
endif
-# TODO: sparc
format_fallback_c = custom_target(
'format_fallback.c',