summaryrefslogtreecommitdiff
path: root/src/mesa/main/tests/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-09-18 21:51:25 -0700
committerMatt Turner <mattst88@gmail.com>2012-10-01 15:23:04 -0700
commitb6651ae6ad314a93287e431a41f5c7a8f8f6c855 (patch)
treea9335e3d7f1b6d9473d917c19f45cc442875b96b /src/mesa/main/tests/Makefile.am
parentdd4fde8f674f5e3efa19e929f97de4ecfd82391b (diff)
build: Use PTHREAD_LIBS and PTHREAD_CFLAGS
Diffstat (limited to 'src/mesa/main/tests/Makefile.am')
-rw-r--r--src/mesa/main/tests/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/mesa/main/tests/Makefile.am b/src/mesa/main/tests/Makefile.am
index cac04bcd6ec..f818e44511c 100644
--- a/src/mesa/main/tests/Makefile.am
+++ b/src/mesa/main/tests/Makefile.am
@@ -1,3 +1,6 @@
+AM_CFLAGS = \
+ $(X11_CFLAGS) \
+ $(PTHREAD_CFLAGS)
AM_CPPFLAGS = \
-I$(top_builddir)/src/gtest/include \
-I$(top_builddir)/src/mapi \
@@ -14,7 +17,8 @@ main_test_SOURCES = \
main_test_LDADD = \
$(top_builddir)/src/mesa/libmesa.la \
$(top_builddir)/src/gtest/libgtest.la \
- -lpthread -ldl
+ $(PTHREAD_LIBS) \
+ $(DLOPEN_LIBS)
if HAVE_SHARED_GLAPI
AM_CPPFLAGS += -DHAVE_SHARED_GLAPI