summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2012-07-08 23:26:11 +0100
committerJon TURNEY <jon.turney@dronecode.org.uk>2012-07-13 12:44:44 +0100
commit99728076ec1a8bd3feb0f23e41198d8d5e56d0c9 (patch)
tree78da932e2a9fe1ea36d27b3ec438b607fdd87d99 /src/mesa/drivers/osmesa/Makefile.am
parentb2a37e242ea60fde6d616814a30b89325875d0df (diff)
Don't explicitly link libOsmesa with libmesa's dependency libglsl
The libmesa convenience library is linked with the libglsl convenience library. libOsmesa is linked with libmesa, and also directly with libglsl. When using libtool, this gives rise to duplicate symbol errors. Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk> Reviewed-by: Eric Anholt <eric@anholt.net> Tested-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
index 9989c92620f..7c151bf705f 100644
--- a/src/mesa/drivers/osmesa/Makefile.am
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -40,8 +40,7 @@ lib@OSMESA_LIB@_la_SOURCES = osmesa.c
lib@OSMESA_LIB@_la_LDFLAGS = -module -version-number @OSMESA_VERSION@ -shared
lib@OSMESA_LIB@_la_LIBADD = \
$(top_builddir)/src/mesa/libmesa.la \
- $(top_builddir)/src/mapi/glapi/libglapi.la \
- $(top_builddir)/src/glsl/libglsl.la
+ $(top_builddir)/src/mapi/glapi/libglapi.la
# Provide compatibility with scripts for the old Mesa build system for
# a while by putting a link to the driver into /lib of the build tree.