summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-01-26 22:37:06 -0500
committerMatt Turner <mattst88@gmail.com>2012-01-30 21:09:18 -0500
commit275ac7e5c1fd6c1847a428192fe259e50690fced (patch)
tree133f533526e15904a3c10b3aa3dee4e11ec43909 /src/mesa/drivers/osmesa/Makefile.am
parente3b520049675f78065eccbc25c001ea77861c129 (diff)
automake: src/mesa/drivers/osmesa
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am82
1 files changed, 82 insertions, 0 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
new file mode 100644
index 00000000000..514e95d0013
--- /dev/null
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -0,0 +1,82 @@
+
+
+# Copyright © 2012 Matt Turner <mattst88@gmail.com>
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+# Hack to make some of the non-automake variables work.
+TOP = $(top_srcdir)
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = osmesa.pc
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/mapi \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mesa/main
+
+LIBADD = \
+ $(top_srcdir)/src/mesa/libmesa.a \
+ $(top_srcdir)/src/mapi/glapi/libglapi.a \
+ $(top_srcdir)/src/glsl/libglsl.a \
+ $(OSMESA_LIB_DEPS)
+
+if BUILD_SHARED
+LIBOSMESA = lib$(OSMESA_LIB).so
+endif
+
+if BUILD_STATIC
+LIBOSMESA = lib$(OSMESA_LIB).a
+endif
+
+if HAVE_OSMESA8
+lib_LTLIBRARIES = libOSMesa.la
+
+libOSMesa_la_SOURCES = osmesa.c
+libOSMesa_la_LDFLAGS = -no-undefined -version-info 8:0:0 #FIXME
+libOSMesa_la_LIBADD = $(LIBADD)
+endif
+
+if HAVE_OSMESA16
+lib_LTLIBRARIES = libOSMesa16.la
+
+libOSMesa16_la_SOURCES = osmesa.c
+libOSMesa16_la_LDFLAGS = -no-undefined -version-info 8:0:0 # FIXME
+libOSMesa16_la_LIBADD = $(LIBADD)
+endif
+
+if HAVE_OSMESA32
+lib_LTLIBRARIES = libOSMesa32.la
+
+libOSMesa32_la_SOURCES = osmesa.c
+libOSMesa32_la_LDFLAGS = -no-undefined -version-info 8:0:0 # FIXME
+libOSMesa32_la_LIBADD = $(LIBADD)
+endif
+
+# Provide compatibility with scripts for the old Mesa build system for
+# a while by putting a link to the library into /lib of the build tree.
+all-local: lib$(OSMESA_LIB).la
+ $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
+if BUILD_SHARED
+ ln -f .libs/$(LIBOSMESA).8.0.0 $(top_builddir)/$(LIB_DIR)/$(LIBOSMESA).8.0.0;
+ ln -f .libs/$(LIBOSMESA).8 $(top_builddir)/$(LIB_DIR)/$(LIBOSMESA).8;
+endif
+ ln -f .libs/$(LIBOSMESA) $(top_builddir)/$(LIB_DIR)/$(LIBOSMESA);