summaryrefslogtreecommitdiff
path: root/src/mapi/Makefile.am
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-01-18 23:43:05 -0800
committerMatt Turner <mattst88@gmail.com>2013-04-15 12:04:25 -0700
commit691c30404d2cb9a562058dd8ab615dd8512c9d23 (patch)
treec199a5eee8ed71e1aadeaf8f7bca3d7a39c1ff88 /src/mapi/Makefile.am
parentd5e9426b9605264608e0b1204ebf818103f1f011 (diff)
build: Get rid of CORE_DIRS
A step toward working make dist/distcheck. Tested-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-and-Tested-by: Andreas Boll <andreas.boll.dev@gmail.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'src/mapi/Makefile.am')
-rw-r--r--src/mapi/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/mapi/Makefile.am b/src/mapi/Makefile.am
new file mode 100644
index 00000000000..ef538039b9a
--- /dev/null
+++ b/src/mapi/Makefile.am
@@ -0,0 +1,42 @@
+# Copyright © 2013 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+SUBDIRS = glapi/gen
+
+if HAVE_SHARED_GLAPI
+SUBDIRS += shared-glapi
+endif
+
+if HAVE_OPENGL
+SUBDIRS += glapi
+endif
+
+if HAVE_OPENGL_ES1
+SUBDIRS += es1api
+endif
+
+if HAVE_OPENGL_ES2
+SUBDIRS += es2api
+endif
+
+if HAVE_OPENVG
+SUBDIRS += vgapi
+endif