summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-05-17 13:44:30 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-05-03 10:58:05 -0700
commitff9bf223c24143260a975f45963eb90f40565c57 (patch)
treec8ec393ae985491da3d8812b36a8be586dbfaaad /src/gbm/meson.build
parentf5eafc2dc6a68c9c2c2660dff528de1ecdedf4dc (diff)
meson: make nm binary optional
This makes nm not required, but used if found. In general I imagine that this means that on windows nm wont be found, and on other platforms it will. v2: - fix gbm and egl symbols check tests to only be run if nm is found - reword commit message to reflect the code change Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index b2ad6673592..b7262c59802 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -66,7 +66,7 @@ pkg.generate(
libraries_private : '-ldl', # FIXME: autotools lists this a incomplete
)
-if with_tests
+if with_tests and prog_nm.found()
test(
'gbm-symbols-check',
find_program('gbm-symbols-check'),