summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2018-11-15 13:54:49 -0800
committerEric Anholt <eric@anholt.net>2018-11-16 17:49:17 -0800
commitd971a4230d54069c996bca78b6ed6a6a23377821 (patch)
tree2d9c29c0c0df5405a0bad5b2c7860bcc614069a2 /src/gbm/meson.build
parentcc198157382a988590b0288d287281139c5f73e6 (diff)
loader: Factor out the common driver opening logic from each loader.
I copied the code from egl_dri2.c, but the functionality was equivalent between all the loaders other than their particular environment variables. v2: Drop the logging function equivalent to loader_default_logger() (requested by Eric, Emil). Move the SCons workaround across. Drop the now-unused driGetDriverExtensions() declaration that was lost in a rebase. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com> (v1) Reviewed-by: Emil Velikov <emil.velikov@collabora.com> (v1)
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index 719f9c1a9b8..007f50a9ae3 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -37,7 +37,6 @@ incs_gbm = [
if with_dri2
files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
deps_gbm += dep_libdrm # TODO: pthread-stubs
- args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_search_path)
endif
if with_platform_wayland
deps_gbm += dep_wayland_server