summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-30 11:30:34 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-31 10:41:19 -0700
commitc16486f5dba0f8316219650f5e31b44a6e46e370 (patch)
treeda800d5c96db90591fa4e8ae691c605224177c4b /src/gbm/meson.build
parent0589331d54396cbcdcf985ba37470e77a4c7bee2 (diff)
meson: Don't link gbm with threads
It's supposed to be linked with pthread-stubs (if the platform needs pthread-stubs). Pthread stubs support isn't (yet) implemented in the meson build, so add a TODO. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index 1bb3c94c387..fc1816cc17a 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -34,7 +34,7 @@ deps_gbm = []
if with_dri2
files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
- deps_gbm += [dep_libdrm, dep_thread]
+ deps_gbm += dep_libdrm # TODO: pthread-stubs
args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir)
endif
if with_platform_wayland