summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-10-11 14:43:35 +0100
committerEric Engestrom <eric@engestrom.ch>2019-07-10 11:27:51 +0000
commitaa6973e6110541d0a6642072f763f550341ed9b3 (patch)
treec599153f9ac5762c8b3316e63fa8386bcbcbbe31 /src/gbm/meson.build
parent1172263c87232d9af5f35a8ea27705c4afb3b8a6 (diff)
gbm: use new symbols check script
Note: the list in gbm-symbols.txt is the same as the one that was in gbm-symbols-check, I just took the opportunity to sort it. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by Dylan Baker <dylan@pnwbakers.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com>
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index b7262c59802..39fa0386a65 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -69,9 +69,12 @@ pkg.generate(
if with_tests and prog_nm.found()
test(
'gbm-symbols-check',
- find_program('gbm-symbols-check'),
- env : env_test,
- args : libgbm,
+ symbols_check,
+ args : [
+ '--lib', libgbm,
+ '--symbols-file', files('gbm-symbols.txt'),
+ '--nm', prog_nm.path(),
+ ],
suite : ['gbm'],
)
endif