summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-20 17:49:42 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-02 11:39:45 -0700
commita29869e8720b385d3692f6a74de2921412b2c8c1 (patch)
tree5e9dab02c13d28896ee151572d6b074ddb38295a /src/gbm/meson.build
parent10d869535cc704c6f787f6759951bb5c87969b29 (diff)
gbm: Don't traverse backwards for includes
This is just a bad idea and should be avoided. Instead, make the #include flat and fix the build systems to pass the proper -I flags v2: - add an inc_wayland_drm instead passing a path to include_directories (Emil) - update commit message (Emil) Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Daniel Stone <daniels@collabora.com> (v1) Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com> (v1)
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index ff3cf3f61d9..437896ef7f0 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -31,6 +31,10 @@ deps_gbm = []
args_gbm = []
links_gbm = []
deps_gbm = []
+incs_gbm = [
+ include_directories('main'), inc_include, inc_src, inc_loader,
+ inc_wayland_drm,
+]
if with_dri2
files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
@@ -40,6 +44,7 @@ endif
if with_platform_wayland
deps_gbm += dep_wayland_server
links_gbm += libwayland_drm
+ incs_gbm += inc_wayland_drm
endif
# TODO: wayland support (requires egl)
@@ -47,9 +52,7 @@ endif
libgbm = shared_library(
'gbm',
files_gbm,
- include_directories : [
- include_directories('main'), inc_include, inc_src, inc_loader,
- include_directories('../egl/wayland/wayland-drm')],
+ include_directories : incs_gbm,
c_args : [c_vis_args, args_gbm],
link_args : [ld_args_gc_sections],
link_with : [links_gbm, libloader, libmesa_util, libxmlconfig],