summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2017-11-02 23:24:00 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2017-11-07 10:47:20 +0000
commit5be1b1a8ce6c635cf0310d2b97056a2b8f11a601 (patch)
treeef0232f3f79b0920e5fe52b80982aa4d80a40ef8 /src/gbm/meson.build
parent0084f4a42290ab54c185c9284a5670d4da4fc66e (diff)
meson: standardize .so version to major.minor.patch
This `version` field defines the filename for the .so. The plan .so as well as .so.$major are always symlinks to this. Unless I'm mistaken, only the major is ever used, so this shouldn't matter, but for consistency with autotools (and in case it does matter), let's always have all 3 major.minor.patch components. (The soname isn't affected, and is always .so.$major) Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index 437896ef7f0..f25f3172027 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -57,7 +57,7 @@ libgbm = shared_library(
link_args : [ld_args_gc_sections],
link_with : [links_gbm, libloader, libmesa_util, libxmlconfig],
dependencies : [deps_gbm, dep_dl],
- version : '1.0',
+ version : '1.0.0',
install : true,
)