summaryrefslogtreecommitdiff
path: root/src/gbm/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-18 12:20:43 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-10-20 16:46:48 -0700
commit108d257a16859898f5ce02f4759c5c58f9b8c050 (patch)
tree0bda907e3e63c9dad56e0656b9336c0ae34a233b /src/gbm/meson.build
parentddf06a05ad32118854136f9ad0bc2a38f41e6430 (diff)
meson: build libEGL
This is based heavily on Daniel Stone's work for the same, rebased on master and with a number of TODO's fixed. This does not implement glvnd (which is coming in a later patch) Meson builds egl slightly differently than autotools, namely it doesn't build an intermediate shared library. It doesn't do this because meson doesn't have problems with the name of the library being dynamically generated, so the glvnd and non-glvnd code can follow the same path. v2: - Don't reuse variable (Eric E.) Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Tested-by: Eric Engestrom <eric.engestrom@imgtec.com> Reviewed-by: Daniel Stone <daniels@collabora.com>
Diffstat (limited to 'src/gbm/meson.build')
-rw-r--r--src/gbm/meson.build12
1 files changed, 10 insertions, 2 deletions
diff --git a/src/gbm/meson.build b/src/gbm/meson.build
index f9665aa2d2f..1bb3c94c387 100644
--- a/src/gbm/meson.build
+++ b/src/gbm/meson.build
@@ -18,6 +18,8 @@
# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
# SOFTWARE.
+inc_gbm = include_directories('.', 'backends/dri')
+
files_gbm = files(
'main/backend.c',
'main/backend.h',
@@ -28,12 +30,17 @@ files_gbm = files(
deps_gbm = []
args_gbm = []
links_gbm = []
+deps_gbm = []
if with_dri2
files_gbm += files('backends/dri/gbm_dri.c', 'backends/dri/gbm_driint.h')
deps_gbm += [dep_libdrm, dep_thread]
args_gbm += '-DDEFAULT_DRIVER_DIR="@0@"'.format(dri_driver_dir)
endif
+if with_platform_wayland
+ deps_gbm += dep_wayland_server
+ links_gbm += libwayland_drm
+endif
# TODO: wayland support (requires egl)
@@ -41,10 +48,11 @@ libgbm = shared_library(
'gbm',
files_gbm,
include_directories : [
- include_directories('main'), inc_include, inc_src, inc_loader],
+ include_directories('main'), inc_include, inc_src, inc_loader,
+ include_directories('../egl/wayland/wayland-drm')],
c_args : args_gbm,
link_args : [ld_args_gc_sections],
- link_with : [libloader, libmesa_util, libxmlconfig],
+ link_with : [links_gbm, libloader, libmesa_util, libxmlconfig],
dependencies : [deps_gbm, dep_dl],
version : '1.0',
install : true,