summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/r600/Makefile.am
diff options
context:
space:
mode:
authorChristian König <christian.koenig@amd.com>2013-04-03 10:18:35 +0200
committerChristian König <christian.koenig@amd.com>2013-04-11 17:10:28 +0200
commit5b2855bfe79bfc3995969f2bf775d89b1bc1808a (patch)
tree5da3383f7c400cc037b6dbaa1695bbdf24b09563 /src/gallium/drivers/r600/Makefile.am
parentf91e4d2c9d714bb7d667956cd93f216c18a434f4 (diff)
radeon/uvd: add UVD implementation v5
Just everything you need for UVD with r600g and radeonsi. v2: move UVD code to radeon subdir, clean up build system additions, remove an unused SI function, disable tiling on SI for now. v3: some minor indentation fix and rebased v4: dpb size calculation fixed v5: implement proper fall-back in case the kernel doesn't support UVD, based on patches from Andreas Boll but cleaned up a bit more. Signed-off-by: Christian König <christian.koenig@amd.com> Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
Diffstat (limited to 'src/gallium/drivers/r600/Makefile.am')
-rw-r--r--src/gallium/drivers/r600/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/gallium/drivers/r600/Makefile.am b/src/gallium/drivers/r600/Makefile.am
index a067f2c4e72..43c8704618d 100644
--- a/src/gallium/drivers/r600/Makefile.am
+++ b/src/gallium/drivers/r600/Makefile.am
@@ -13,12 +13,14 @@ AM_CFLAGS = \
libr600_la_SOURCES = \
$(C_SOURCES)
+libr600_la_LIBADD = ../radeon/libradeon.la
+
if R600_NEED_RADEON_GALLIUM
libr600_la_SOURCES += \
$(LLVM_C_SOURCES)
-libr600_la_LIBADD = ../radeon/libllvmradeon@VERSION@.la
+libr600_la_LIBADD += ../radeon/libllvmradeon@VERSION@.la
AM_CFLAGS += \
$(LLVM_CFLAGS) \